Tales From A Lazy Fat DBA

Den of an Oracle DB Performance freak & a fan of Cassandra, MySQL and PostgreSQL …

  • Likes

    • 122,951
  • Archives

  • Categories

  • Subscribe

  • Advertisements


Today’s Topic:

Date: 01/05/2018
Discussion Number: 03
Issue/Problem statement: Error while starting a database instance on 3.10.0-327.el7.x86_64 hosted on ASM (Non RAC system)

SQL> startup
ORA-01078: failure in processing system parameters
ORA-01565: error in identifying file '+DG_DATA_01/BSCS03/spfile.ora'
ORA-17503: ksfdopn:2 Failed to open file +DG_DATA_01/BSCS03/spfile.ora
ORA-15056: additional error message
ORA-17503: ksfdopn:2 Failed to open file +DG_DATA_01/BSCS03/spfile.ora
ORA-04031: unable to allocate 40 bytes of shared memory ("shared pool","unknown object","KKSSP^31","kglseshtSegs")
ORA-06512: at line 4

Cluster Resources

All DG’s (Including DATA DG) are already mounted.

Disk Group Sector Block Allocation
Name Size Size Unit Size State Type Total Size (MB) Used Size (MB) Pct. Used
-------------------- ------- ------- ------------ ----------- ------ --------------- -------------- ---------
DG_ARCH_01 512 4,096 1,048,576 MOUNTED EXTERN 409,600 282,498 68.97
DG_DATA_01 512 4,096 1,048,576 MOUNTED EXTERN 3,072,000 3,035,718 98.82
DG_REDO_01 512 4,096 1,048,576 MOUNTED EXTERN 51,200 12,118 23.67
DG_REDO_02 512 4,096 1,048,576 MOUNTED EXTERN 51,200 12,118 23.67
--------------- --------------
Grand Total: 3,584,000 3,342,452


ASMCMD> lsdg
State Type Rebal Sector Block AU Total_MB Free_MB Req_mir_free_MB Usable_file_MB Offline_disks Voting_files Name
MOUNTED EXTERN N 512 4096 1048576 409600 127102 0 127102 0 N DG_ARCH_01/
MOUNTED EXTERN N 512 4096 1048576 3072000 36282 0 36282 0 N DG_DATA_01/
MOUNTED EXTERN N 512 4096 1048576 51200 39082 0 39082 0 N DG_REDO_01/
MOUNTED EXTERN N 512 4096 1048576 51200 39082 0 39082 0 N DG_REDO_02/


SQL> show parameter asm_diskgroups;

------------------------------------ ----------- ------------------------------
asm_diskgroups string DG_REDO_01, DG_REDO_02, DG_ARC

Somehow no alert log is available to study – someone deleted.

One of the last trace file shows something i failed to relate.

*** 2018-01-03 14:28:15.863
kwqpshnfy_1: enter
kwqpshnfy_1: exit
Deallocate SGA space
Deallocation successful
KJHA:2phase clscrs_flag:1040 instSid:TESTDBDIX

*** 2018-01-03 14:28:17.473
KJHA:2phase ctx 1 clscrs_flag:1040 instSid:TESTDBDIX
KJHA:2phase clscrs_flag:1040 dbname:TESTDBDIX
KJHA:2phase ctx 1 clscrs_flag:1040 dbname:TESTDBDIX
KJHA:2phase WARNING!!! Instance:TESTDBDIX of kspins type:1 does not support 2 phase CRS

What could be the issue ????

Comments ??


Problem with Oracle 12c Installation on RHEL6.

Error Logs: installActions2013-06-29_12-50-04AM.log – Notepad

Hi Everyone,


Hope everyone of us are quite excited after the release of Oracle 12c r1 database and all of us are ready to test new features packed inside the ‘New Red’

But it seems like i have to wait to perform some tests and learn more about the 12c.


Today I’ve downloaded software from oracle official website:

Oracle Database 12c Release 1 ( for Linux x86-64

Download linuxamd64_12c_database_1of2.zip (1,361,028,723 bytes) (cksum – 3389130601)
Download linuxamd64_12c_database_2of2.zip (1,116,527,103 bytes) (cksum – 273248753)


and i have already created a brand new Red Hat 6 machine (64 Bit) to install the package and wet my hands with it,


Here is the situation/problem:

I’ve completed all pre–requisites and checks e.g. installed all needed rpm’s

Modified profiles and kernel parameters

Made changes to ‘limits.conf’ file

Created required usergroups and user accounts

Set SELINUX to permissive

Set the DISPLAY and launched the .runInstaller


Everything went perfect –

~ Prepare  — Completed

~ Copy Files — Completed

While ‘Linking Libraries’ step received an error message which says about which i skipped and soon after that got many different errors related to linking, which i again skipped.

Same has happened during ‘Net Configuration Step’ and ‘DB Configuration Assistant’, which i again skipped (Otherwise the message keeps on coming on screen)


After that I’ve executed root.sh and related scripts from root account.


But now after this installation has completed (With many errors related to linking and Configuration files), I’m not able to launch the sqlplus executable. Even after setting the ORACLE_BASE, ORACLE_HOME.



Database: Oracle 12c Release 1

Package Name: Oracle Database 12c Release 1 ( for Linux x86-64

Files: linuxamd64_12c_database_1of2.zip  and linuxamd64_12c_database_2of2.zip

OS Version:

[oracle@oracle12c ~]$ uname -a

Linux oracle12c 2.6.32-71.el6.x86_64 #1 SMP Wed Sep 1 01:33:01 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

[oracle@oracle12c ~]$ uname -m





First error reported during ‘Linking Libraries Stage’

“Error in invoking target ‘client_sharedlib’ of makefile ‘/u01/app/oracle/product/12.1.0/db_1/rdbms/lib/ins_rdbms.mk

See /u01/app/orainventory/logs/installactions2013-06-29_12-50-04AMlog for details.


Screen Buttons:



* Tried zillion times to RETRY but no luck, hence have to continue/skip the problem.

Please click below provided link to access/read orainventory installation log files.

installActions2013-06-29_12-50-04AM.log – Notepad


Other Errors (After this faulty Installation)

[oracle@oracle12c ~]$ sqlplus / as sysdba

sqlplus: error while loading shared libraries: /u01/app/oracle/product/12.1.0/db_1/lib/libclntsh.so.12.1: file too short



[oracle@oracle12c ~]$ dbca

UnsatisfiedLinkError exception loading native library: njni12

java.lang.UnsatisfiedLinkError: /u01/app/oracle/product/12.1.0/db_1/lib/libnjni12.so: /u01/app/oracle/product/12.1.0/db_1/lib/libclntsh.so.12.1: file too short

Exception in thread “main” java.lang.UnsatisfiedLinkError: oracle.net.common.NetGetEnv.get(Ljava/lang/String;)Ljava/lang/String;

at oracle.net.common.NetGetEnv.get(Native Method)

at oracle.net.config.Config.getNetDir(Unknown Source)

at oracle.net.config.Config.initConfig(Unknown Source)

at oracle.net.config.Config.<init>(Unknown Source)

at oracle.sysman.assistants.util.NetworkUtils.<init>(NetworkUtils.java:298)

at oracle.sysman.assistants.util.step.StepContext.<init>(StepContext.java:371)

at oracle.sysman.assistants.dbca.backend.Host.<init>(Host.java:941)

at oracle.sysman.assistants.dbca.wizard.UIHost.<init>(UIHost.java:243)

at oracle.sysman.assistants.dbca.wizard.InteractiveHost.<init>(InteractiveHost.java:58)

at oracle.sysman.assistants.dbca.wizard.InteractiveHost.getInstance(InteractiveHost.java:71)

at oracle.sysman.assistants.dbca.Dbca.getHost(Dbca.java:168)

at oracle.sysman.assistants.dbca.Dbca.execute(Dbca.java:113)

at oracle.sysman.assistants.dbca.Dbca.main(Dbca.java:184)



Suggestions Required.





Hi Everyone,

I’ve recently created an ASM instance on one of my Test DB Machine which has 10g R2 installed on Red Hat Linux 5 platform . It was absolutely good until a recent system issue which forced us to reboot machine and soon after the machine is up and we tried starting ASM instance it’s prompting following errors on the terminal which reads:

[oracle@localhost ~]$ export ORACLE_SID=+ASM
[oracle@localhost ~]$ sqlplus / as sysdba

SQL*Plus: Release – Production on Fri Oct 12 18:59:37 2012
Copyright (c) 1982, 2005, Oracle. All rights reserved.
Connected to an idle instance.

SQL> startup
ORA-15032: not all alterations performed
ORA-15063: ASM discovered an insufficient number of disks for diskgroup “‘+TESTDB_DATA1′”

OR Sometimes

ORA-29701: unable to connect to Cluster Manager
Then i tried to check the status of raw disks I’ve made during the Failgroup creation and found the permissions has somehow reverted back to root:root which should be oracle:oinstall in place for all raw disks.

[root@localhost ~]# cd /dev/raw
[root@localhost raw]# ls -ltr
total 0
crw——- 1 root root 162, 1 Oct 12 18:58 raw1
crw——- 1 root root 162, 2 Oct 12 18:58 raw2
crw——- 1 root root 162, 3 Oct 12 18:58 raw3
crw——- 1 root root 162, 4 Oct 12 18:58 raw4

(There are four raw disks and raw 1 and raw 2 part of Failgroup 1 and raw 3 and raw 4 is Failgroup 2)

so, i manually changed the permissions again to oracle:oinstall and modified the mode to 660 and then tried to start the ASM instance and as per my expectations it started working good.
But to test i rebooted machine again after this permissions and mode change and it’s started doing the same and permissions and ownership rolled back to root:root

Below are the contents of boot up script– /etc/rc.d/rc.local

[root@localhost raw]# vi /etc/rc.d/rc.local

# This script will be executed after all the other init scripts.
# You can put your own initialization stuff in here if you don’t
# want to do the full Sys V style init stuff.

touch /var/lock/subsys/local

/sbin/losetup /dev/loop1 /asmdisk/disk1
/sbin/losetup /dev/loop2 /asmdisk/disk2
/sbin/losetup /dev/loop3 /asmdisk/disk3
/sbin/losetup /dev/loop4 /asmdisk/disk4
raw /dev/raw/raw1 /dev/loop1
raw /dev/raw/raw2 /dev/loop2
raw /dev/raw/raw3 /dev/loop3
raw /dev/raw/raw4 /dev/loop4

Any Suggestions ???


3 Responses to “Discussions”

  1. Dan Brown said

    Everything Seems perfect. Have you tried to reboot your machine after saving changes ?
    Am i Correct ???

    Sybase Corp (SAP Company)

  2. Mahi said

    Nee ayya solution eedi ra bodi ga

  3. tj said

    solution please !!!!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: